PDA

View Full Version : v13 printing problems


JackH
10-15-2002, 06:07 PM
Ever since upgrading to v13 I have had printing problems. Most frequesnt is if trying to print 2 reports, like an invoice and a packing slip, to fast in sucession PT will lock up and the only way out is to Ctl-Alt-Del.

The bigger problem is longer reports like when doing the end of month transfer reports, the report will fail part way through with a stack error. This just happened to me while printing checks. It printed 12 of 18 checks. #13 printed the top stub only and on check #15 printed the following error message:

ERROR: syntaxerror
OFFENDING COMMAND: binary token, type=156

STACK:

107
4883
900
0

Can anyone help?

Jack

chikamic
10-31-2002, 05:21 AM
What operating system are you using? (Need to know where to place an environmental variable).

JackH
10-31-2002, 07:08 AM
I am using Windows 98 SE and a HP LaserJet 6MP. I think the problem may be with the printer timeout setting. It seem that whenever printing a longer report is when it happens the most. I am going to try and set the timeout for a longer period.

Also, if you hit the Enter or Escape key while the "printer progress" window is displayed you can lock up the software.

Jack

chikamic
10-31-2002, 07:13 AM
Add the following variable to your AUTOEXEC.BAT (make it the first line)

SET OVERLAY_HEAP=1

JackH
10-31-2002, 07:21 AM
The line is already there.

Jack

chikamic
10-31-2002, 07:25 AM
Is it the first line??

JackH
10-31-2002, 07:26 AM
YES!

JackH
10-31-2002, 07:27 AM
chicamic,

if you would like to email me directly it is esp@usa.net

Jack

chikamic
10-31-2002, 07:28 AM
Try using a generic laserjet driver like a IIP and see what happens

JackH
10-31-2002, 07:36 AM
Benn there, done that! I have tried many different configurations. I have even updated the HP drivers. In my experience it appears that this is not a problem that can be solved by external changes but is a problem with the internal code of the PT to Windows printing interface.

It looks like v13 is still "printing" in DOS to a PT created "print redirector" that then interfaces with the Windows standard print mechanism. If all other apps print OK to the windows side why doesn't PT.

Jack

chikamic
10-31-2002, 07:40 AM
Make sure that you do not have your printers set up as Direct, that seems to be a problem as well.

JackH
10-31-2002, 07:47 AM
Thanks for trying. I am very familier with PT DOS printers. My CPA who as probably 50 PT DOS clients even calls me for printer help.

This is a PT coding/implemetation problem not a user configurations problem unless PT has left out some instructions. I have spent about 3 hours on the phone with PT with no results.

Jack

chikamic
10-31-2002, 07:55 AM
I beg to differ, I have quite a few clients who have converted to v13 with no problems, I know because I have completed the conversions myself. There are quirks in the software for sure but some have been able to make it work, so that indicates to me (and I am a MCSE) that there is some variable in the environment that is causing the problem.

Printer codes are no longer hard coded into the program and that seems to be what is confusing the program. I have been working with PCA for over 10 years and have never experienced anything like what is happening with v12 & 13. But of course these things are to be expected when a product undergoes a complete platform change.