PDA

View Full Version : File System Error 100 - Help


oic pchuser
08-04-2004, 01:27 PM
I'm using Peach 7.0 on a Win 98 OS. Inventory reports are inaccurate so I attempted to run an Integrity Check. During the Inventory/Journal Sync Test I received a File system error number 100 in sortjob.dat.

Can anyone offer assistance?

Jim Dale
08-11-2004, 04:37 PM
You need to setup files and buffers. Is this a new install? Also, One reason to upgrade is that the sortjob file was prone to errors. You can delete it and let it rebuild.

oic pchuser
08-12-2004, 07:57 AM
Thanks Jim,

No this is not a new install. We have been using 7.0 for a few years. The upgrades have not included anything that warrants the cost thus far. We are now trying to decide if we should upgrade or make a change in accounting systems.

If I delete the sortjob.dat file, will it create other problems or will it simply rebuild the file as it should be?

Thanks - I appreciate the help. - Edie

TheWolf
08-12-2004, 08:46 AM
Version 7 is very prone to this error in the sortjob file, if you have alot of company data. I have not see an increase in files and buffers correct this as it is usually the registry setting that is too low or the process of running the inv/journal sync takes all of the available buffers, no matter how high you set it.

I recommend deleting the sortjob file with Peachtree closed and allowing it to rebuild. Then try a purge on the data. The purge routine in version 7 is not that great and may not remove enough data. If after the purge, you still get the error, you will want to upgrade to at least 2003. The purge routine was improved starting with 2003. After you upgrade, then run the purge routine. Also, if 2003 is still open, you will want to close 2003 before you do a purge.

Jim Dale
08-12-2004, 09:26 AM
The problem is cache size.

Peachtree's standard answer is: If you are using Peachtree First Accounting, Peachtree Accounting or Peachtree Complete Accounting 7.0 or higher, you will need to download and execute the registry file rel7reg.reg. This file will increase the memory allocated for Peachtree to use as well as increase other settings. The file can be found by going to http://www.peachtree.com/html/updates_available.cfm. Look for the link for Peachtree Release 7 Registry Update. Follow the directions on the website to download and execute the file. This file must be executed on each worksation if you are in a multi-user environment.

This link is no longer necessary on their website. You probably have to edit the settings using regedit.

I WOULD NOT purge unless you know your backup is good. I would also make sure that you optimize the settings for win 98. This means files and buffers also. If they are not already set, files should be at least 199 and buffers 32,0

TheWolf
08-13-2004, 11:15 AM
Offering the benefit of first hand experience with this error message; you can max your cache to the maximum and still get the error if there is too much data in the company. I have corrected this error many times but only after I have trimmed the database size down, and that is why I recommend a purge.

Starting with release 7, Peachtree is now a 32-bit application and looks to the registry for most settings. In release 7 and abaove, I have not seen files and buffers have an effect on the program, except when dealing with the old fixed assets program which is still 16 bit.

oic pchuser
08-16-2004, 07:57 AM
Thank you Tom and Jim both. We will be looking at your suggestions this week. - Edie