No announcement yet.

Unable to Open Company File in Shared Folder

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to Open Company File in Shared Folder

    I installed Peachtree Complete on a pc as a server. The OS is WinXP Home. I created a shared folder named Peachtree Data under the Shared Documents folder. I didn't want to use the recommended location under Program Files. The installation is as a server only, no user interface.

    I installed PT Complete on a desktop pc. The OS is Vista Home Premium. The installation seemed to go fine; no issues. I opened PT and tried to set up the company which again went without issue. However, when I tried to save the company, I got an error message stating that the system was unable to open the company file. I have attached a screen shot of the error message and the dialogue box that shows the data path.

    I read and followed the suggested Help text which suggested to add a user: SYSTEM and assign Full control rights. I checked this on the server and the SYSTEM user was already present with Full Control. (I had to add the Security Configuration tool to be able to do so as the Security Tab does not show in WinXP Home unless you're in Safe Mode.)

    Back on the desktop pc, I accessed one of the text files in Peachtree Data and did a "save as" and it worked. It seems that I have full read/write rights to the company folder.

    Having been bit by Vista a few times, I thought that I'd post this note before I spend a lot more time on this issue. Any help would be appreciated.

    I have also installed PT Complete on another PC with WinXP Home and I have the same issue. I am also able to access a text file in the company directory and save changes so the read/write permissions appear to be ok.
    Last edited by cbalogh05; 07-10-2009, 08:08 PM. Reason: Additional Information

  • #2
    Seemingly you have mapped a drive letter right into Peachtree and or your Company data folder on the host computer. The image showing the error is not clear, so I may be wrong.

    Assuming that you install the complete Peachtree program on the host computer in a folder such as C:\Peachtree Data\Peachtree\Company\, then your drive mapping should be similar to the following P: = \\Host\Peachtree data\Peachtree\. This will allow your Datapath in the Peachtree PCW160.INI, located in the C:\Windows folder on the workstation, to read P:\Company\ . The INI file varies with the version of Peachtree that you have installed.

    Peachtree Complete 2008 = PCW150.INI
    Peachtree Complete 2009 = PCW160.INI
    Peachtree Complete 2010 = PCW170.INI
    Rick Prindiville
    PCO Consulting Services, Inc.
    Peachtree Certified Consultant
    Sage Certified Trainer


    • #3
      Thanks Rick. I have included a few more screen shots. There are two that show how drive Y: is mapped. Another is a screen shot of the .ini file -- it looks correct. I also provided a screen shot of the "Open Company" dialogue box that clearly shows that the drives mapped to the correct company folder in the PeachTree Data folder. I had to delete one file due to the 5 file limit.

      I disabled my firewall and it made no difference. I also am unable to open either of the example company files that were provided.

      In your reply, you commented that your assumption was that I installed "the complete Peachtree program on the host computer....." This is not the case. I was given an option during the install to not install the User interface portion of the program on the host (server) which I chose to do. At this point, I cannot run PT from the server. Might this be the issue?

      As you can see from the screen shots, I did NOT use the default data location. Could this make a difference. What doesn't make sense is that I was able to create two (2) Companies (PTMI and Triskelion) which means that PT was able to write to the Host (server).
      Last edited by cbalogh05; 07-11-2009, 07:16 AM. Reason: More information


      • #4
        Unable to open the shared folder.

        Look at the following article on Peachtree's website.

        To resolve - share the folder above Peachtree Data with full permissions and map the workstation to it using the same letter Y. Then update the datapath in the ini file from Y:\ to Y:\Peacht~1\ on the workstations. (This DOS convention assumes that there are not any other folders on the server called Peachtree.)


        • #5
          Thank you Clarence. The Peachtree article was what I used to fix this. In my case, I had specified the datapath and drive directly to the "Peachtree data" folder. I remapped the drive to the next higher folder (in this case, "Shared Documents" - i.e. c:/Documents and Settings/All Users/Shared documents/Peachtree data/ -- originally I had mapped the data drive right to Peachtree Data.) I did have to reinstall the program on the clients but it came ups just fine after that.

          Thank you again.